Friday, June 25, 2010

I've been MIA...

..... Life as I know it has caught up with me.  We've had unbelievable BAD car luck...

Scooter's brake lines broke as he was approaching a red light, he was able to slow down a little but ended up rear ending a lady.  Everyone is fine.... $400 for the brake line repair $75 towing and we're still waiting for the final word on the repair bill from the lady.  Note: He had new brake pads and rotors done a couple months ago.  Brake lines can appear to be fine but can go at any time, no warning. 

So while his car was in the shop getting fixed, I let him drive MY car..... He was leaving the gym and it stalled.... what??? 

It turned out to be the distributor assembly...got it towed for $65 and another whopping $400 to get fixed.  Once it was home, I cleaned her out and made her pretty...then went took take her for a spin...she stalled out in the street in front of my house.  What????  Finally got her to started again and gimped her to the mechanic.... The problem was that my spark plug wires were arcing...corroded from humidity.... most likely the reason of how the distributor assembly fried....another $260 and she's back on the road again.

We're back to a full fleet of cars and LIFE is good!

Cha-ching!  :o)

3 comments :

Sarah said...

Ouch... and all at once too! :( Glad everything getting back to normal. Hope you have a wonderful summer. :)

mustavcoffee said...

Rotten luck, lets hope it's all over now and plain sailing from here on in, fingers crossed for you,xx

Alice Wertz said...

glad to hear that no one was hurt during all the unfortunate events. so happy that it's all good now. hope you have a wonderful weekend!